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1
Converting Dimensions to Measures

& Changing Data Types

When it connects to a data source, Tableau takes a best guess at the type of data contained in each 
column of your database. Tableau assigns a data type such as Number, Date, String (Text), and so 
on, to each column. Depending on the data type, it classifies each column as either a dimension 
or measure. Dimensions contain categorical data such as Customer Names, Dates, and Regions. 
Measures contain quantitative data such as Sales, Profit, and Duration. If Tableau misidentifies your 
data, you can change the data type and convert dimensions to measures and vice versa.

Your changes are saved with the workbook. If you connect to this database often, you may want to 
save the connection. That way you don’t have to do all this clean-up every time you connect. Select 
the data source on the Data menu and then select Add to Saved Data Sources.

To change the data type:
Right-click the field in the Data window and select Change 
Data Type. Then, select a new data type.

To convert dimensions:
Drag the field from the Dimensions area to the Measures 
area in the Data window.

You can convert measures back to dimensions just by 
dragging and dropping between the two areas in the 
Data window.
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2
Setting Field Defaults

Aggregation, Sort Order, Number Format

There are many defaults you can specify for the data fields in your view. For example, you can specify 
a default aggregation so that measures are always aggregated correctly. You can also set a default 
sort order so that the values are always sorted correctly when you drop a field on the shelf. Finally, 
you can specify a default number format so that every time you use the “Sales” field it is formatted as 
currency.

To specify a field default:
Right-click a field in the Data window and select Field Properties.

Then, depending on the type of field, select one of the following options:
•	 Aggregation - controls how measures are aggregated when used in the view (e.g., sum, average, etc.)
•	 Number Format - controls how numbers are displayed (e.g., percentage, currency, etc.)
•	 Date Format - controls how dates are displayed (e.g., Monday June 23, 2009, 06/29/09, etc.)
•	 Comment - a description of the field that displays when resting the pointer over the field in the Data window
•	 Aliases - alternative names for members of a dimension
•	 Color - the color encoding used when the field is placed on the Color shelf
•	 Shape - the shape encoding used when the field is placed on the Shape shelf
•	 Sort - the order in which the members of a dimension are shown in the view
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3
Automatic Updates

Increase Performance for Large Data

When you connect to data using Tableau, you set up a live connection to the data source. Each time 
you drag a field to the view, a query is sent to the data source. Depending on the size of your data 
source and how it is set up, you may have to wait while these queries are executed. One way to 
improve performance is to temporarily pause these queries by disabling Automatic Updates.

To pause Automatic Updates:
Click the Automatic Updates button on the toolbar so it is no longer highlighted.

Drag fields to the view, change aggregations, add filters, and any other changes you want to make. When you make these 
changes, the view is lightened to indicate that the view hasn’t been updated yet.

To manually run a query:
Click the Run Query button on the toolbar. All of the changes you made to your view are sent to the data source at once, 
along with any possible query optimizations. 



TIPS & TRICKS
BEGINNER SECRETS

Copyright © 2011 Tableau Software, Incorporated and its licensors. All rights reserved. Patents pending.

4
Combine Date Fields
Handling Split Date Parts 

Tableau handles dates differently than how it handles other dimensions. You can view dates in 
several different ways. For example, you can view the Exact Date, which shows every individual date 
along a continuous axis. Alternatively, you can break the date into its parts such as Year, Quarter, 
Month, and so on. Using these date parts allows you to pivot the view and find hidden trends. Change 
the way you look at dates using the field menu for the date field.

Sometimes, you may find that the dates in your underlying data are split across multiple columns. For 
example, you may have a Year field, a Month field, and a Day field. In order for Tableau to recognize 
these columns as a single date field, you need to write a calculated field that combines them.

Select Analysis > Create Calculated Field then write the following formula:

DATETIME(
	 STR([Order Year])+ “-”+    
	 STR([Order Month])+ “-”+
	 STR([Order Day])
)

This formula converts each field containing a 
date part into a STRING, thus building a text 
string in the format “Year-Month-Day”.  

Then string is then converted that string into 
a DATETIME.

Type the 
formula 
into the 
Calculated 
Field dialog 
box.
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5
Dashboard Layout Containers

Create Dynamic Areas that Resize to the Content

A dashboard is a collection of several worksheets and supporting information shown in a single 
place so you can compare and monitor a variety of data simultaneously. Dashboards can contain 
worksheets and other objects such as images, text, and more. One type of dashboard object is a 
Layout Container. Layout containers help you organize sheets and other objects on a dashboard. 
These containers create an area in the dashboard where objects automatically adjust their size and 
position based on the other objects in the container.

Without Layout Containers
The map view is set up to filter the Customer Details. When no 
marks are selected in the map, all details are excluded. Because 
each view is a fixed size, the dashboard has a large white space at 
the bottom.

With Layout Containers
The map and the details are arranged inside a Vertical 
Layout Container. So when no details are showing, the map 
automatically expands to fill the extra space.

Use a Vertical Layout container when you want the objects to resize up and down, and a Horizontal 
Layout Container when you want the objects to resize side to side.
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6
Clipboard Data Sources

Use the clipboard to pull data from an external source for some quick analysis. Rather than create 
a data source for the external data and then connect to it, you can copy the data and paste it into 
Tableau. Copy data from applications such as Microsoft Excel and Word, or from HTML tables in 
webpages.    

When you save the workbook, the data is saved as a data source in your Tableau Repository. You 
can then connect to the new data source from other workbooks.  

Copy Data
Right-click and 
copy the data 
from the external 
source. 

Paste Data
Select Data > Paste Data in Tableau. The data will 
display automatically in your view.
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7
Top N Filters

Using Parameters

There are many types of filters you can use to narrow down the data in your view. One such filter is 
the Top N filter. The purpose of a Top N filter is to show only the top members of a dimension based 
on a measure value. For example, in a view that displays profits based on location, you can create a 
Top N filter to show the top 10 most profitable states. 

Replace the constant value that you set in the Top N filter with a parameter so you can dynamically 
control the value of n. Right-click the Data window, and select Create Parameter. Once you create 
the parameter, right-click the filter and select the parameter you just created from the drop-down list. 

Create Parameter
Create a parameter that can display a range of n values.

Edit Filter
Edit the Top 
N filter 
to use the 
parameter 
you just 
created. 

Create Filter
Create a filter to show the top 10 profitable states.

Top N Filter

Parameters
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8
Formatting

Font & Tooltips

Not only is formatting important to how your view looks, it’s an important part of your analysis. 
Formatting can increase readability and help reveal trends in your data more quickly. Using the 
Format window, you can format font, alignment, shading, borders, graph lines, reference lines, and 
more. 

Format Text Font
Improve the readability of a plain text table by 
formatting the text. Select Format > Font then 
open the Header control.

Format Tooltips
Tooltips provide additional information about specific marks and are a good way to show details for 
specific fields in your view. Select Worksheet > Tooltips to format the tooltip. Tooltip formatting 
applies to each sheet.

Format Number Font
Specify the number format for both the axis 
and marks. In the Format window, select a field 
on the Fields menu, then open the Numbers 
control.
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9
Copy & Paste

Formatting, Fields, & Sheets

To copy formatting:
Go to the sheet you want to copy the formatting 
from, right-click the sheet tab, and then select 
Copy Formatting. Then, go to the sheet you want 
to apply the formatting to, right-click the sheet tab, 
and then select Paste Formatting.

To copy sheets:
Copy sheets from one workbook to another 
by saving it as a Bookmark. Select Window 
> Bookmark > Create Bookmark. Open the 
new workbook and drag the Bookmark file onto 
the new workbook.  

To copy fields in your view:
Copy fields to different parts of your view by 
holding down the CTRL key while dragging the 
field to another shelf.

To copy calculated fields:
Right-click the calculation and then select 
Copy. In the destination workbook, right-click 
in the Data window and select Paste.

Save time by copying and pasting some of the work you’ve done to other areas of your worksheet 
or workbooks that use the same data source. Copy and paste formatting, worksheets, fields already 
used in a view, and custom calcuations. 
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Control Size when Sharing

with Fixed-Size Dashboards

By default, views scale to fill the entire window. Therefore, the size of your view can vary from 
computer to computer, depending on the screen resolution and the size of the application or browser 
window. When you share dashboard views with others, you can specify the size for the dashboard to 
ensure a consistent layout and experience.  

There are several size options available to you. Use the Range option to set a minimum and 
maximum size for the dashboard. Your view will scale between the specified sizes, providing an 
optimum range for others to access your dashboard without scroll bars or extra white space.

Fix Dashboard Size
Set a minimum and maximum size to allow 
your dashboard view to scale within an 
optimum range.

To set the dashboard size:
Click Edit in the Size area of the Dashboard window. In the Page Setup dialog box, click the 
Dashboard Size tab. Select Range, under the Minimum area, select Standard and select a 
minimum screen resolution size. Repeat this step for Maximum.
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11
Saving Your Work

Tableau File Types

When saving your work you should know about the following types of Tableau files:

To save a workbook or packaged workbook:
Select File > Save As. In the Save dialog box, select a location then select whether to save the file as 
a workbook or a packaged workbook.

Contains one or 
more worksheets, 

dashboards, 
and connection 

information. Does 
not contain data.

A “zip” file containing 
the workbook plus 

all local files (Excel, 
Access, local cubes, 

images, shapes, 
geocoding, etc.)

An individual 
worksheet and 
its connection 

information. Cannot 
be a dashboard.

Shortcut to a data 
source connection. 

Contains connection 
information as well 

as user defined 
fields.

Contains a local 
copy of all or a 
subset of the 

original data source. 
Data is stored in 
the Tableau Data 

Engine.


